What DotNetNuke versions do you support?

We support all versions of DNN from 4.x.x to the newest 7.x.x version. You can even run DNN 3.x.x versions on our servers. However, if you are running a version of DNN older than version 4.9.5 then we strongly recommend upgrading your DNN site to at least version 4.9.5 to protect your site against known security vulnerabilities in DNN versions older than 4.9.5.

Was this answer helpful?

 Print this Article

Also Read

Unable to login to DNN site. Login link does not work.

If you are experiencing an issue with your login link not working properly, or refreshing your...

Error: Event Viewer is currently unavailable

When accessing DNN even viewer you get following error message: Error: Event Viewer is currently...

DNN login link redirects to home page

The tab id for your portal in your site's database got set to the home page tab id.  There...

Rectify error "Cannot insert the value null into column 'default language'" in DNN 5.1.2 installations.

There is a known issue with DNN 5.1.2 installations which will cause the error "Cannot insert the...

Error: Edit Text/HTML is currently unavailable

Unhandled error loading module. DotNetNuke.Services.Exceptions.ModuleLoadException:...